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Key points on Carimas

• A general PET or medical imaging data analysis tool

• Developed in Turku PET Centre and Turku 
University Hospital

• Widely used for PET imaging data analysis around
the world

• Two versions: Carimas Research and CarimasCE

• All the organs and tissues can be analyzed using it, 
including heart, liver, kidney and brain ect (human
and animal) 



Carimas

For researchers:  to provide a complete package for analyzing 

their PET-related imaging data. Specially, using this 

package, users can perform the following tasks easily:

1) visualization, 2) segmentation, 3) modelling and  4) reporting

For software developers: to provide a development 

platform. Using a plug-in capability, software developers 

can easily develop their own applications for medical 

imaging visualization and analysis tools and implemented 

them into Carimas.
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Carimas is a general medical imaging processing platform developed in Turku PET Centre in 
Finland. 
Originally, Carimas was designed for visualization, segmentation and modelling of PET data only. However, 
the latest versions support processing of imaging data from most medical imaging modalities, such as CT 
and MRI.





Google Scholar: Carimas, 2024, 55 papers found, based on Carimas analysis



A research paper on infarcted heart from China published on Nature Communication 2024



A research paper from Turku PET Centre (Riku Klen’s group) on machine learning
Published on Nature Scientific Reports, 2024



Turku PET Centre, Finland
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Journal of Neuroscience: IF=6.16

Rat PET brain function study



Accepted by EANMMI IF=9.2

Contribution of Carimas in this study

1. A template of rab brain was created
2. Copy of CT VOIs to PET imaging
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Mono will be used to generate Linux and Unix version

TPClib is developed in TPC, C# code, dataIO and modelling etc.

C#

.NET 

TPClib

Carimas



Main GUI of Carimas

1. MenuStrip 2. Toolbar 3. Extra Toolbar 4. Image visual panel

5. Side panel 7. View poart6. Status bar



Carimas setting

1: PC IP address

2: DICOM 3.0

3: a free port 
number

1: ADW workstation IP 
address2: Port: ADW port number

3: a PC free port number 
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Setting of ADW workstation and PC with Carimas

Key points:
1. IP address must be matched each other.
2. Port number must be same.
3. PC listening port must be free, not be occupied.

ADW

PC

Carimas supports multi-PACs Dicom data communication

Parametric images can be sent to selected PACs system after modelling in 
Polarmap window



https://carimas.fi/

Carimas website

Carimas is a general medical imaging processing platform developed in Turku PET Centre in Finland. Originally, Carimas was designed for 
visualization, segmentation and modelling of PET data only. However, the latest versions support processing of imaging data from most medical 
imaging modalities, such as CT and MRI.
Using Carimas, you can easily visualize your imaging data in many different ways, such as in 2D or 3D, or fuse images from different modalities 
(PET/CT, PET/MRI). Furthermore, Carimas provides a lot of advanced functions for researchers. For example, using ROI/VOI tools, the user can 
draw a region/volume of interest in manual, semi-automatic or automatic manner; using the modelling tools, the user can perform advance d 
analysis for his/her research data; using Heart tools, cardiac researchers can easily analyze their PET studies.

https://carimas.fi/


Installation and license

• System requirements:
.NET 4.0+ for (2.10) or 2.0+ for older. 

• Currently, both CarimasCE and Research are commercial.

License files can be loaded into Carimas from the help 
menu. Getting the full version requires registration. The 
registration can be done from the help menu. License file 
will be then sent to you that unlocks full functionality of the 
software.

• Windows installers (msi installer):
Carimas 2.10

• All operating systems (zip archive):
Carimas 2.10

http://www.microsoft.com/net
http://turkupetcentre.fi/_carimas/files/archive/Website/Download/Carimas2_10_common.msi
http://turkupetcentre.fi/_carimas/files/archive/Website/Download/Carimas2_10_common.zip
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Models implemented in Carimas
1. Compartment model 

1. Tracer-specific model for heart

1. 15O labeled water perfusion model (1TCM)

2. 11C labeled acetate perfusion model (1TCM)

3. 82Rb rubidium perfusion model (1TCM)

4. 13N labeled ammonia perfusion model 

1. UCLA model (simplified 1TCM)

2. Duke model (simplified 2TCM-K3)

3. Michigan model (full 2TCM)

5. 18F labeled flurpiridaz perfusion model (2TCM,K3)

2. General model

1. 1-tissue compartment model

2. 2-tissue compartment model(k3)

3. 2-tissue compartment model (k4)

4. 3-tissue compartment model in parallel

5. 3-tissue compartment model in series

2. Graphical analysis method

1. Patlak

2. Logan

3. Kmono

TCM=tissue compartment model



K1

K2

Ca C1

15O-labeled radio water cardiac perfusion model
1-tissue compartment model
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Input function metabolite correction
options:
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Summary of 3 common-used N13-ammonia models

Modelling





Features 1/3

• Input
• Multiple image data format support: DICOM, ECAT, Analyse, Interfile, Nifti, Interfile, 

MicroPET and general bitmap formats (JPG, TIFF, PNG and BMP)
• PACS support: available to connect to hospital PACS system

• Visualization
• View images from transaxial, coronal, sagittal or any free direction
• 3D view with color rendering or MIP
• Move and rotate images freely in 3D space
• Visualize image histograms or cut profiler lines

• Static image tools
• Calculate VOI statistics: mean, maximum, minimum, standard deviation, volume, etc…
• SUV and percentage units

• Dynamic images tools
• Easy and fast visualization of dynamic data
• Calculate sum or difference images, or view individual frames
• Analyze time activity curves from VOIs or individual voxels



Features 2/3

• Segmentation tools
• 2D ROI sets or 3D VOIs
• Histogram tool for selecting voxels at value range.
• Start region definition from some predefined 3D shape or draw your own
• Create VOIs using masking and countour tools
• Some 3D region growing segmentation tools exist also as separate plugin, like “syringe” 

and threshod tools
• Scale, move rotate, smooth, combine the VOIs with easy visual tools
• Save and reuse the VOIs in multiple studies, regardless of image type or resolution

• Image fusion
• File format independent image positioning
• Coregistrate PET/MR/CT automatically

• Modeling
• Use data from images or data files
• Specify model parameters values and limits
• Rescale data, define time ranges and exclude time points
• Calculate parametric images from any model and parameter (separate plugin)



Features 3/3

• Existing models (trial has only first two)
• Linear regression
• Exponential fitting
• Patlak
• Logan
• FUR index
• Tracer specific models for water (with special license), ammonia, rubidium, acetate and 

flurpiridaz
• Generic compartment models

• Tools for heart analysis
• Semi-automatic heart segmentation with manual modification tools
• Analyze polarmaps in 3, 4 or 17 segment modes, pixel by pixel or draw your own ROI to 

polarmap
• Use any models from the Carimas modelling library to create parametric polarmaps
• Compare results side by side or save to data files

• Lots of other features as plug-ins
• Add to program easily from Carimas menu by just checking them from list
• List of currently existing plug-ins can be found here: Go to external plugins archive

http://turkupetcentre.fi/carimas/files/archive/SecondaryModules4.xml


CarimasCore

Plugin API

1: included in release 
package

2: published on 
Carims website, 
downloadable, needs
to install separately

type

3: user-developed. 
Rights belong to 
developers.

Plugin in Carimas



Plugin is an extentional functions, which can be developed by other developers, not only from
Carimas developers
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Dicom anonymization plugin of Carimas

PC

Very effectively and easily anonymize Dicom data

Download and installation of plugin
1. Help->Download Plugin
2. On Carimas plugin website, select: Dicom anonymization plugin
3. Restart Carimas. 

Anonymize Dicom data

Step 2: Select data folder

Step 1: 
• Start Carimas
• Edit->Other commands->Dicom anonymize plugin 

Step 3: Anonymize also subfolder?. If yes: anonymize all data in 
subfolder. If no: only data in selected folder will be anonymized

Step 4: Remove all or only name and ID

Step 5: option: overwrite or not? Step 6: Select a folder for saving anonymize data Step 7: Processing data and progress bar



Frame concatenation plugin

Key points:
1. This plugin is to concatenate single frame images to a complete dynamic data set.
2. From most scanners, dynamic images from all frames locate in one folder, from which Carimas can 

load all data at once. However, in some cases, frame images can be saved in separated folders. 
Therefore it needs to add all data into one folder.

3. .sif file is needed to hold frame timing information. 

Important
• Version of 1.2.00 has bug, please update to 1.1.00
• If you have installed 1.2.00, you have to reset: Help-

>Download Plugins, then Reset to Default Configuration. 
• Restart Carimas, don’t install.

Start: Edit->Other commands->FrameConcatenationPlugin

FrameConcatenationPlugin GUI: 
Two options to combine
1. Main and background images. 
2. Many images with same size from disk.

You can add frame one by one by button of “Add more”, but more efficient way is to drag and drop by mouse

Multiple selection/Drag and 
drop

by mouse

1. Frame order is created based on file order, which is often not correct, you can modify them by “Move down” 
and ”Move up” buttons. Then,  click button of “Combine”, a dialog for saving folder will come. 

2. Combined data will be saved in dicom format in selected folder. 
3. You have to create a .sif file containing frame information and put it in the same folder, then Carimas will load 

dynamic data correctly.

.sif file is an ASCII format, more 
details to see from
http://www.turkupetcentre.net/petanalysis/sif.ht
ml

One folder contains a frame image data One folder holds all frame image data

http://www.turkupetcentre.net/petanalysis/sif.html


Carimas plugin: Image Export Tools/Export Visual Image
Function: to export currently visualized images in format of Dicom.
Features:
1. Currently visualized images can be exported in Dicom, such as sum image, diff image or single frame from dynamic data set.
2. Additionally, cropped images, images with user-defined value in masked regions and images with reduced bit can also be exported accordingly.

Example: heart volume is generated as a new data 
set

Installation of this plugin: Help->Download Plugins
In plugin list, select “Image Export Tools” 

Start of plugin: Click left button of mouse on main 
images. On drop-down menu: Image Filter->Export 
Visual Image

Usage
1. Save dynamic as static by using current frame 

display settings: depending on user’s sitting, sum 
images, diff images, or single frame images can be 
saved and exported.

2. Crop same values around the image (and write 
smaller image):

• VOIs are needed firstly defined and selected
• Image->Show/Hide voxels->Show voxels 

outside…
3. Replace currently masked region with one custom 

pixel value: voxel in cropped volume will be filled 
with new value.

4. Reduce the number of exported colors: exported 
image bit will be replaced with new value.

Main GUI of Image Export Tools



Generating paramatric images in Carimas using plugin of “Parametric image filter”

Key points:
1. All models implemented in Carimas can be used to generate parametric image (pixel-based 

parametric image).
2. Only pixels inside of selected ROIs/VOIs are calculated.
3. Output is dicom file, each of model parametres locates in its own folder.
4. It may be a time-consuming process, depending number of selected pixels, model and hardware 

system.

Download and installation of plugin of “Parametric image filter”.
1. This plugin is not default in Carimas.
2. It is a free-downloadable plugin from Carimas website.
3. Carimas->Help->Download plugins.
4. Select “Parametric image filter”.
5. Download and save it in a folder.
6. Carimas->Edit->Extra plugin folder: select plugin-saved folder
7. Restart Carimas.

Step of “Parametric image filter”.
1. Load image.
2. Core->Segment->Define ROIs or VOIs. These include 

regions or volumes not only as parametric outputs, but 
also as input function.  

3. Core->Analysis->Select a model, and define input function 
ROI or VOI.

4. Core->Segment->select ROIs or VOIs, in which parametric 
will be generated.

5. Core->Load: in image list, on select an image to click left 
button. On drop-down list, select “Parametric image 
filter”

6. On file dialog: select a folder for saving output parametric 
image.

7. Results: parametric images will be outputted in two ways:
• Saved in selected folder as dicom files. Each 

subfolder holds a parametric. Subfolder name is 
parametric name.

• Parametric images are added to image list.

Step 1 Load image

Step 2 Define ROIs/VOIs

Step 3 Select a model

Step 4 Select ROIs/VOIs

Step 5 To run parametric image filter

Step 6 Select folder for 
output

Step 7 Results

By Chunlei Han, Aug. 30,2020, Turku PET Centre, Turku, Finland



ImageIF
A Carimas plugin for image-

derived input function

Chunlei Han, MD, Ph.D

Turku PET Centre and Turku University Hospital, 
Finland

May 1, 2022, Turku, Finland



Installation and Run

Installation

1. Save ImageIF v0.1 package on local disc.

2. Carimas Edit->Extra plugin folder.

3. Locate ImageIF v0.1 folder.

4. Restart Carimas.

Run

1. Edit->Other commands->ImageIF v0.1



Image-derived input function

• For PET modelling, input function is the key data 
with PET imaging data. Ideally, it should be taken
from the arteris nearing target organs or tissues. 

• In practice, it is difficulty to perform.

• Image-derived input function is a method to take
input function from image rather than from arteries
using non-invasive procedures.

• ImageIF is a plugin for Carimas to extract IDIF from
PET image based on MRA arterial anatomic volume
for PETMRI dynamic studies.



Keys of ImageIF

• A plugin of Carimas. It means that this package can only be run
with Carimas.

• It is desiged to process brain PETMRI data with both dynamic PET 
and MRA (MR angiography).

• It may work for brain PETCT data with both dynamic PET and CT 
angiograpy (not test yet).

• SimpleITK is implemented in this package for segmentation and 
convolution.

• Segmentation is semi-automic: seeds, low and high values are
needed. 

• Three accessory tools included: VOIfromMask and ”Delete other
image files”(remove of other images but not mainImage and 
backgroundImage). Thes two plus ImageIF can be found in 
Edit/Other commands. The third is MetCorrAmmonia (in Anayze-
>Curve->Curve filter.



Load images: 
1. dynamic PET as mainImage
2. MRA as backgroundImage

Load predefined seed VOIs and subvolume or
define them manually in Carimas Core Segment: 

Fit seed VOIs and subvolume to you data manually

Give a low and high volume for segmentation. 
Note that the low value plays key role. 

Start ”ImageIF”: Edit->Other commands->ImageIF
v0.1

Analyze: select a model and input function: 
PVE_IF_metcorr is PVE and metabolic corrected

input function.

Modeling. Fit

Workflow of ”ImageIF”



New images after running of ”ImageIF”

Subvolumes of PET and MRI defined by ”subvolume”

Segmented arterial mask. This is import for quality
control. If not good enough, location of seeds and low
and high values are needed to be modfied and 
perform ”ImageIF” again until this mask is satisfied. 



Predefined subvolume

subvolume

1. Subvolume is a domain for segmentation.
2. You can modify it to fit your data (cover seed VOIs).
3. Only one subvolume is needed. If more than one subvolume, only first one is used, others ignored.
4. You can define your subvolume, but name must be ”subvolume…..”.
5. Subvolume should not contain cerebral tissue.
6. More bigger subvolume, more time will be taken for processing (most for deconvolution procedure). 



Predefined four seed VOIs for segmentation

seed_right_1 seed_left_1

sedd_left_2

seed_left_1
seed_right_1
seed_right_2
sedd_left_2

seed_right_2

1. You can use 1, 2, 3 or 4 of four previousely defined seed VOIs.
2. Program only uses VOIs with name of ”seed_.....”. So if you only use one, you must remove ”seed” from

other VOI names. Such as on the right definition, only first VOI is used.  
3. You must modify the locations of VOIs to fit your data (to arteries).
4. You can use your own defined VOIs (must name them with ”seed……”).
5. Seed VOIs must be inside of subvolume.
6. Size of seed VOIS does not matter, program only uses the centre as seed location in segmentation.
7. Number of seed VOIs has no limit, but you must define at least one.  

seed_left_1
_right_1
_right_2
_left_2



Pixel values of low and high limts on MRA 
PET

mainImage
MRA

backgroundImage

Alpha
For fuse

Low value high value

3D transverse

Segmentation result

Alpha
For fuse Low value

high value

This is an example of setting and its segmentation result
• Low value plays a key role in segmentation, but high value does

not. If segmentation is not good, you need to modify low value to 
perform segmentation again until satified.

Important factors of segmentation
1. Seed location (important)
2. Low value (very important)
3. High value (not very important)



Algorithm of ”ImageIF”

Segmentation based on 
MRA

Mapping MRA 
mask to PET 
domain

VOI1 and VOI2 / RC 

PSF
(point spread function)

Curve

Semi-automatic
Depends on location of 
seed, low and high
values

Automatic



Based on Iida 2013: https://www.sciencedirect.com/science/article/pii/S0168900212009084?via%3Dihub

VOI1_mask_image

RC_image

convolution

VOI2_mask_image

Dilate VOI1/2_image

RC1/2_image

PET_mask_image_dilated

subtract

Ca_mask_image

multiply

Single frame image

R1/2

Sum1/Sum2Nmask1/2

divide

C1/2

multiply

C1(t)=R1*Ca(t)+(1-R1)*Ct(t)
C2(t)=R2*Ca(t)+(1-R2)*Ct(t)

divide

Ca(t)

PET_dynamic_imagePET_mask_image MRA_mask_image PSF_imageInput

Output

(1,2,3….n)

(1,2,3….n)

Workflow of Image-derived input function

Chunlei Han. MD, Ph.D
Turku PET Centre and Turku University Hospital of Finland 

https://www.sciencedirect.com/science/article/pii/S0168900212009084?via%3Dihub


Based on Iida 2013: https://www.sciencedirect.com/science/article/pii/S0168900212009084?via%3Dihub

Implementation of Iida’ algorithm

https://www.sciencedirect.com/science/article/pii/S0168900212009084?via%3Dihub


BSA_Calculator v0.2
A Carimas plugin to calculate BSA(body surface area) based on total body CT images

Chunlei Han, MD, Ph.D

Turku PET Centre and Turku University Hospital, 
Finland

May 12, 2022, Turku, Finland



Algorithm of BSA_Calculator

Remove bed based on VOIs with names of ”bed….”

Mask body aerial cavities basd on 
VOIs with names of ”bodymask”

Generation of body masked
image with low pixel limit of -500 

(CT  Hounsfield units)

Generation of triangle mesh of 
masked body

Calculation of summy of 
triangle polgyon area in body

mesh

BSA: body surface area

Origimal images

After bed removed

Masked total body

Triangle mesh of total body



https://www.calculator.net/body-surface-area-calculator.html

Example case: female, 46kg of weight, 160cm of height

BSA from BSA_Calculator: 1.36 m2

BSA estmated based on body weight and height

https://www.calculator.net/body-surface-area-calculator.html


Carimas plugin: RSReader (Radiotherapy structure reader)

Abbreviation:

RD: Radiotherapy dose
RP:  Radiotherapy plan
RS:  Radiotherapy structure

Step 1: File->Open Step 2: Dicom RT LOAD Step 3: Select RS Step 4: Option to change mask color

Step 5: Uptake value or curves or modelling
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Conclusions

• Carimas is useful tools for medical imaging-related
researchers

• Additional functions can be very easily extended by
plugin



Kiitos
Thank for your attention


